Mantis Bugtracker

Viewing Issue Simple Details Jump to Notes ] View Advanced ] Issue History ] Print ]
ID Category Severity Reproducibility Date Submitted Last Update
0000054 [MyDNS-NG] Global minor always 2010-05-12 17:19 2010-10-31 00:40
Reporter rhardy View Status public  
Assigned To itamarjp
Priority normal Resolution fixed  
Status resolved   Product Version 1.2.8.27
Summary 0000054: compiling recent mydns-ng with a strict C compiler results in parse errors
Description Trying to build the current source tree results in parse errors when using a compiler with a strict interpretation of C89/C99 (ex. gcc 2.96). mydns-1.1.0 compiles fine with the same compiler.
Additional Information The attached patch also applies cleanly to a SVN checkout as of yesterday.

According to the C irc channel the code where the parse errors are occuring is actually invalid before the attached patches are applied and newer compilers should generate parser errors. They do not.
Tags patch
Attached Files ? file icon mydns-1.2.8.27.1-fixes.diff [^] (3,852 bytes) 2010-05-12 17:19

- Relationships

-  Notes
(0000151)
itamarjp (developer)
2010-05-12 17:56

looks good.
(0000155)
itamarjp (developer)
2010-05-13 17:01

+ k = 0;
+ item = NULL;
       for (k = 0; k < numfds; k++) {

patch commited, I have removed k = 0, because for (k = 0) already set it to 0

- Issue History
Date Modified Username Field Change
2010-05-12 17:19 rhardy New Issue
2010-05-12 17:19 rhardy File Added: mydns-1.2.8.27.1-fixes.diff
2010-05-12 17:19 rhardy Tag Attached: patch
2010-05-12 17:56 itamarjp Note Added: 0000151
2010-05-13 17:01 itamarjp Note Added: 0000155
2010-06-29 19:49 jwarnier Issue Monitored: jwarnier
2010-10-31 00:40 itamarjp Status new => resolved
2010-10-31 00:40 itamarjp Resolution open => fixed
2010-10-31 00:40 itamarjp Assigned To => itamarjp


Mantis 1.1.6[^]
Copyright © 2000 - 2008 Mantis Group
Powered by Mantis Bugtracker